IGS-4215-24P4X – Planet Industrial L2+ 24-Port 10/100/1000T 802.3at PoE + 4-Port 10G SFP+ Managed
Engineered for demanding industrial environments, the IGS-4215-24P4X is PLANET’s latest DIN-rail Layer 2+ managed Gigabit switch, delivering an optimal balance of performance and reliability. It supports advanced IPv4/IPv6 dual-stack networking and integrates a high-performance Layer 2/Layer 4 switching engine for flexible and efficient network management.
Equipped with 24 10/100/1000BASE-T 802.3at PoE+ ports, the switch provides a high-density power solution with a total PoE budget of up to 480 watts, along with 4 10GBASE-X SFP+ fiber slots for high-speed uplink connectivity—ideal for bandwidth-intensive industrial applications.
Built for harsh conditions, it operates reliably within a wide temperature range of -40 to 75°C and features a rugged IP30-rated aluminum enclosure. A USB Type-C console port ensures easy and efficient management, making it a dependable solution for mission-critical industrial networks.
- Key Features
- Specifications
- Applications
Physical Port
- 24 10/100/1000BASE-T Gigabit Ethernet RJ45 ports
- PoE Functionality:
- 24 ports with IEEE 802.3at PoE+ injector function
- 4 10GBASE-SR/LR SFP+ slots, backward compatible with 100M/1G/2.5GBASE-X SFP
- One USB Type C console interface for basic management and setup
Power over Ethernet
- Complies with IEEE 802.3at Power over Ethernet Plus/end-span PSE
- Powers up to 24 ports of IEEE 802.3at PoE+ devices
- Supports PoE power up to 36 watts for each PoE+ port
- Remote power feeding up to 100 meters in standard mode and 250m 15W in extended mode
- PoE budget
- Dual power input: 480W
- Single power input: 240W
- Auto detects powered devices (PDs)
- Circuit protection prevents power interference between ports
- PoE management
- Total PoE power budget control
- Per port PoE function enable/disable
- PoE port power feeding priority
- Per PoE port power limitation
- PD classification detection
- Intelligent PoE features
- Temperature threshold control
- PoE extension
- PD alive check
- PoE schedule
Industrial Case and Installation
- IP30 aluminum case
- DIN-rail and wall-mount designs
- 48~54V DC (redundant power with reverse polarity protection)
- Supports 6KVDC Ethernet ESD protection
- -40 to 75 °C operating temperature
Digital Input and Digital Output
- 2 digital input (DI)
- 2 digital output (DO)
- Integrate sensors into auto alarm system
- Transfer alarm to IP network via SNMP trap
Switching
- Hardware-based 10/100Mbps (half/full duplex), 1000Mbps (full duplex), auto-negotiation and auto MDI/MDI-X
- IEEE 802.3x flow control for full duplex operation and back pressure for half duplex operation
- 32K MAC address table size
- 12K jumbo frame
- Automatic address learning and address aging
Layer 3 IP Routing Features
- Supports maximum 32 static routes and route summarization
- Routing interface provides per VLAN routing mode
Layer 2 Features
- Supports VLAN
- IEEE 802.1Q tagged VLAN
- Provider bridging (VLAN Q-in-Q, IEEE 802.1ad) support
- Protocol VLAN
- Voice VLAN
- Private VLAN (Protected port)
- Management VLAN
- GVRP
- Supports Spanning Tree Protocol
- STP (Spanning Tree Protocol)
- RSTP (Rapid Spanning Tree Protocol)
- MSTP (Multiple Spanning Tree Protocol)
- STP BPDU Guard, BPDU Filtering and BPDU Forwarding
- Supports Link Aggregation
- IEEE 802.3ad Link Aggregation Control Protocol (LACP)
- Cisco ether-channel (static trunk)
- Maximum 8 trunk groups, up to 8 ports per trunk group
- Supports port mirror (many-to-1)
- Loop protection to avoid broadcast loops
- Supports ERPS (Ethernet Ring Protection Switching)
- Link Layer Discovery Protocol (LLDP)
Quality of Service
- Ingress/Egress Rate Limit per port bandwidth control
- Traffic classification
- IEEE 802.1p CoS
- TOS/DSCP/IP precedence of IPv4/IPv6 packets
- Strict priority and Weighted Round Robin (WRR) CoS policies
Multicast
- Supports IPv4 IGMP snooping v2, v3
- Supports IPv6 MLD snooping v1, v2
- IGMP querier mode support
- IGMP snooping port filtering
- MLD snooping port filtering
Security
- Storm Control support
- Broadcast / Multicast / Unknown Unicast
- Authentication
- Built-in RADIUS client to cooperate with the RADIUS servers
- DHCP Option 82
- RADIUS/TACACS+ authentication
- Access Control List
- IPv4/IPv6 IP-based ACL
- IPv4/IPv6 IP-based ACE
- MAC-based ACL
- MAC-based ACE
- MAC Security
- Static MAC
- MAC filtering
- Port security for source MAC address entries filtering
- DHCP snooping to filter distrusted DHCP messages
- Dynamic ARP inspection discards ARP packets with invalid MAC address to IP address binding
- IP source guard prevents IP spoofing attacks
- DoS attack prevention
Management
- IPv4 and IPv6 dual stack management
- Switch Management Interface
- Web switch management
- Console/Telnet Command Line Interface
- SNMP v1 and v switch management
- SSHv2, TLSv1.3 and SNMP v3 secure access
- SNMP Management
- SNMP trap for interface Link Up and Link Down notification
- Four RMON groups (history, statistics, alarms and events)
- User privilege levels control
- Built-in Trivial File Transfer Protocol (TFTP) client
- Static and DHCP for IP address assignment
- System Maintenance
- Firmware upload/download via HTTP/TFTP
- Configuration upload/download through HTTP/TFTP
- Dual images
- Hardware reset button for system reboot or reset to factory default
- SNTP Network Time Protocol
- Network Diagnostic
- Cable diagnostics
- ICMPv6/ICMPv4 Remote Ping
- SFP-DDM (Digital Diagnostic Monitor)
- Link Layer Discovery Protocol (LLDP) Protocol and LLDP-MED
- Event message logging to remote syslog server
- PLANET Smart Discovery Utility for deployment management
- PLANET NMS, NMSViewerPro App and, CloudNMS for deployment management
| Hardware Specifications | |
|---|---|
| Copper Ports | 24 10/100/1000BASE-T RJ45 auto-MDI/MDI-X ports (Ports 1 to 24) |
| PoE Injector Port | 24 ports with 802.3at PoE+ injector function (Ports 1 to 24) |
| SFP+ Ports | 4 10GBASE-SR/LR SFP+ interfaces (Port XG1 to Port XG4) Backward compatible with 1G/2.5GBASE-SX/LX/BX SFP transceivers |
| Console | 1 x USB Type C to RS232 serial port (115200,8, N, 1) |
| Reset Button | < 5 sec: System reboot > 5 sec: Factory default |
| Connector | Removable 6-pin terminal block Pin 1/2 for Power 1; Pin 3/4 for fault alarm; Pin 5/6 for Power 2 Removable 6-pin terminal block for DI/DO interface Pin 1/2 for DI 1 & 2, Pin 3/4 for DO 1 & 2, Pin 5/6 for GND |
| Alarm | One relay output for power failure. Alarm relay current carry ability: 1A @ 24V AC |
| Digital input (DI) | 2 digital input (DI): Level 0: -24V~2.1V (±0.1V) Level 1: 2.1V~24V (±0.1V) Input load to 24V DC, 10mA max. |
| Digital output (DO) | 2 digital output (DO): Open collector to 24V DC, 100mA max. |
| Power Requirements | 48~54V DC, 12A (max.) |
| Power Consumption/ Dissipation | DC (system on) Max. 8.5 watts / 28.9BTU DC (Full loading) Max. 544 watts/1,855BTU |
| Dimensions (W x D x H) | 96 x 135 x 152 mm |
| Weight | 1,840g |
| Enclosure | IP30 aluminum case |
| Installation | DIN-rail kit and wall-mount ear |
| ESD Protection | Contact Discharge 6KV DC Air Discharge 8KV DC |
| LED | System: Power 1 (Green) Power 2 (Green) Alarm (Red) Ring (Green) R.O. (Green) I/O (Red) Per 10/100/1000T RJ45 PoE+ Port: Up 1000 LNK/ACT (Green) 10/100 LNK/ACT (Amber) Down PoE-in-Use (Amber) Per 10G SFP Interface: 1G/2.5G LNK/ACT (Green) 100/10G LNK/ACT (Amber) |
| Switching Specification | |
| Switch Architecture | Store-and-Forward |
| Switch Fabric | 128Gbps/non-blocking |
| Switch Throughput@64 bytes | 95.23Mpps @64 bytes |
| MAC Address Table | 32K entries |
| Shared Data Buffer | 12Mbits |
| Flow Control | IEEE 802.3x pause frame for full duplex Back pressure for half duplex |
| Jumbo Frame | 12 Kbytes |
| Power over Ethernet | |
| PoE Standard | IEEE 802.3at Power over Ethernet Plus/PSE |
| PoE Power Supply Type | End-span |
| Power Pin Assignment | 802.3at PoE: End-span: 1/2(+), 3/6(-) |
| PoE Power Output | IEEE 802.3af Standard Per port 48V~51V DC, max. 15.4 watts IEEE 802.3at Standard Per port 51V~54V DC, max. 36 watts |
| PoE Power Budget | Single power input: 240W maximum (depending on power input) Dual power input: 480W maximum (depending on power input) ※Dual power input must be the same as DC voltage, like dual 54V. |
| Max. Number of Class 2 PDs (~6.5 watts) | 24 |
| Max. Number of Class 3 PDs (~13 watts) | 24 |
| Max. Number of Class 4 PDs (~25.5 watts) | 18 |
| PoE Management Functions | |
| PoE Management | PD Alive Check Scheduled Power Recycling PoE Schedule PoE Usage Monitoring PoE Extension |
| Enhanced PoE Mode | Standard/Legacy/Force |
| Active PoE Device Live Detection | Yes |
| PoE Power Recycling | Yes, daily or predefined schedule |
| PoE Schedule | 4 schedule profiles |
| PoE Extend Mode | Yes, max. up to 250 meters |
| Layer 2 Functions | |
| Port Mirroring | TX/RX/Both Many-to-1 monitor Up to 4 sessions |
| VLAN | 802.1Q tagged VLAN 802.1ad Q-in-Q tunneling (VLAN stacking) Voice VLAN Protocol VLAN Private VLAN (Protected port) GVRP Management VLAN Up to 256 VLAN groups, out of 4094 VLAN IDs |
| Link Aggregation | IEEE 802.3ad LACP and static trunk Supports 8 groups with 8 ports per trunk |
| Spanning Tree Protocol | IEEE 802.1D Spanning Tree Protocol (STP) IEEE 802.1w Rapid Spanning Tree Protocol (RSTP) IEEE 802.1s Multiple Spanning Tree Protocol (MSTP) STP BPDU Guard, BPDU Filtering and BPDU Forwarding |
| IGMP Snooping | IPv4 IGMP snooping v2, v3 IGMP Querier Up to 256 multicast groups |
| MLD Snooping | IPv6 MLD snooping v2, v3, up to 256 multicast groups |
| Access Control List | IPv4/IPv6 IP-based ACL/MAC-based ACL IPv4/IPv6 IP-based ACE/MAC-based ACE |
| QoS | 8 mapping IDs to 8 level priority queues Port number 802.1p priority DSCP/IP precedence of IPv4/IPv6 packets Traffic classification based, strict priority and WRR Ingress/Egress Rate Limit per port bandwidth control |
| Ring | Supports ERPS, and complies with ITU-T G.8032 Recovery time < 450ms |
| Layer 3 Functions | |
| IP Interfaces | Max. 64 VLAN interfaces |
| Routing Table | Max. 32 routing entries |
| Routing Protocols | IPv4/IPv6 hardware static routing |
| Security Functions | |
| Access Control List | IPv4/IPv6 IP-based ACL/MAC-based ACL IPv4/IPv6 IP-based ACE/MAC-based ACE Max. 256 ACL entries |
| Port Security | Built-in RADIUS client to co-operate with RADIUS server RADIUS/TACACS+ user access authentication |
| MAC Security | IP-MAC port binding MAC filtering Static MAC address, max. 256 static MAC entries |
| Enhanced Security | DHCP Snooping and DHCP Option82 STP BPDU guard, BPDU filtering and BPDU forwarding DoS attack prevention ARP inspection IP source guard |
| Management Functions | |
| Basic Management Interfaces | USB to RS232 Console Web browser Telnet SNMP v1, v2c |
| Secure Management Interfaces | SSHv2, TLSv1.3, SNMP v3 |
| System Management | Firmware upgrade by HTTP/TFTP protocol through Ethernet network Configuration upload/download through HTTP/TFTP LLDP protocol SNTP PLANET Smart Discovery Utility PLANET NMS, NMSViewerPro App and CloudNMS |
| Event Management | Remote/Local Syslog System log |
| SNMP MIBs | RFC 1213 MIB-II RFC 1215 Generic Traps RFC 1493 Bridge MIB RFC 2674 Bridge MIB Extensions RFC 2737 Entity MIB (Version 2) RFC 2819 RMON (1, 2, 3, 9) RFC 2863 Interface Group MIB RFC 3635 Ethernet-like MIB RFC 3621 Power Ethernet MIB |
| Standards Conformance | |
| Regulatory Compliance | FCC Part 15 Class A, CE |
| Stability Testing | IEC 60068-2-32 (free fall) IEC 60068-2-27 (shock) IEC 60068-2-6 (vibration) |
| Standards Compliance | IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet/IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus/IEEE 802.3at Power over Ethernet Plus IEEE 802.3bt Power over Ethernet Plus Plus IEEE 802.3az for Energy-Efficient Ethernet RFC 768 UDP RFC 783 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2 ITU-T G.8032 ERPS Ring |
| Environment | |
| Operating Temperature | -40 ~ 75 degrees C |
| Storage Temperature | -40 ~ 85 degrees C |
| Humidity | 5 ~ 95% (non-condensing) |






